五好的Book

安装 swoole 报的错 Unable to load dynamic library swoole

由于服务器安装了多个php版本,采用官方文档的 安装命令后, 启用模块后发现报了这个错误提示
Unable to load dynamic library 'swoole'
折腾过程滤过:
最后的解决之道
编译对应版本时 一定要执行 make clean 后 再执行 官方的 安装步骤
再然后 就是 编译对应的版本,要指定对应版本的配置文件
例如:

sudo ./configure --with-php-config=/usr/bin/php-config7.4

本原创文章未经允许不得转载 | 当前页面:五好的Book » 安装 swoole 报的错 Unable to load dynamic library swoole

评论

文章评论已关闭!