钉钉 linxu GLIBC_2.29 中文输入的问题
侧边栏壁纸
  • 累计撰写 190 篇文章
  • 累计收到 28 条评论

钉钉 linxu GLIBC_2.29 中文输入的问题

五好
2022-03-23 / 0 评论 / 490 阅读 / 正在检测是否收录...

钉钉出linux版本,非常好, 但是在ubuntu下用默认 的输入法框架ibus 是没法 输入中文的 ,这个反馈过钉钉,但是一直没有解决,后在网络上搜索解决办法 ,找到了解决办法。
主要是这个文件 /opt/apps/com.alibabainc.dingtalk/files/Elevator.sh

export XMODIFIERS="@im=fcitx"
export QT_IM_MODULE="fcitx"
export QT_QPA_PLATFORM=xcb 

主要是这里指定了 fcitx

所以我把这3行注释了 就可以输入中文了,
网上的 是 改 fcitx 为 ibus

还有如果启动时候的报错

./libm.so.6: version `GLIBC_2.29' not found (required by /lib/x86_64-linux-gnu/libcairo.so.2)

这个问题其实只要删除

/opt/apps/com.alibabainc.dingtalk/files/1.3.0-Release.20214/ 
libm.so.6 这个文件删除  即可
0

评论 (0)

取消